EcoRenovator  

Go Back   EcoRenovator > Improvements > Geothermal & Heat Pumps
Advanced Search
 


Blog 60+ Home Energy Saving Tips Recent Posts Search Today's Posts Mark Forums Read


Reply
 
Thread Tools Display Modes
Old 05-22-20, 03:02 PM   #1
scottmcll
Lurking Renovator
 
Join Date: Sep 2015
Location: WA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Split air handlers fuses blown

Hello All! I successfully installed a split air system in my home about 5 years ago with help from this forum, and have been enjoying it every year as it gets warmer and warmed in the Pacific NW. I have three indoor air handlers: a 18k BTU ceiling cassette type, and two wall mounted units, one with 12k and the other with 9k. Last used the system in late September last year, had some warm weather a few weeks ago so turned on the ceiling unit, it started up and worked perfectly. (As did the outdoor unit). I then went to fire up the two others, both dead a a door nail. Checked incoming power on each, present on both. Then extracted the control boards (no easy task) to discover the single fuse on both boards were blown. Replaced the fuses, checked for continuity, and reassembled, still completely dead, tho the new fuses did not blow. I have ordered two new control boards but am leary of just installing them without getting some feed back from folks here. We're not prone to power surges in my area and I find it really odd that this happened to two of the three units and while the units were turned off sometime during the winter. Could some other component within the air handler, other than the circuit board, have caused this and might fry the new boards I install? Sorry for the long read, and I would sincerely appreciate any and all thoughts.

scottmcll is offline   Reply With Quote
Old 05-24-20, 12:44 AM   #2
jeff5may
Supreme EcoRenovator
 
Join Date: Jan 2010
Location: elizabethtown, ky, USA
Posts: 2,353
Thanks: 369
Thanked 593 Times in 496 Posts
Send a message via Yahoo to jeff5may
Default

More information is needed to be of assistance. What make and model is the system and components? Did you see anything burnt or discolored or strange on the control boards?
jeff5may is offline   Reply With Quote
Old 07-10-20, 03:06 AM   #3
WyrTwister
Master EcoRenovator
 
Join Date: Jun 2013
Location: USA
Posts: 543
Thanks: 6
Thanked 44 Times in 38 Posts
Default

Could have taken a severe power hit / surge ? Do the PC boards smell burned ?

Do you have a volt / ohm meter ? If so , check for good voltage coming into the indoor units . I think the power for the indoor units comes from the out door unit ? Check if the outdoor unit is providing power , at its terminal board . Look for fuses inside the out door unit .

Check the indoor unit fans for open and / or ground .

God bless
Wyr

WyrTwister is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:45 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Ad Management by RedTyger
Inactive Reminders By Icora Web Design