View Single Post
Old 06-24-20, 09:30 AM   #8
jeff5may
Supreme EcoRenovator
 
Join Date: Jan 2010
Location: elizabethtown, ky, USA
Posts: 2,372
Thanks: 390
Thanked 601 Times in 503 Posts
Send a message via Yahoo to jeff5may
Default

If you didn't submit registration paperwork, your warranty is moot. It had to have been given a thumbs up by a licensed HVAC tech and submitted within 90 days. The approving tech is supposed to put a valid EPA license number on the warranty registration in order for the manufacturer to honor anything. The tech support crews only want to deal with licensed techs, not end-user customers. I imagine you didn't spend 5000 dollars on the system, so even if you have to buy a new board, you'll still come out way ahead.

Ok so here's what I would do:

Check the motor out. Find the LRA (locked rotor amps) and RLA (running load amps) for the motor. LRA is usually like 10x the running amps.

Grab a blade fuse holder and electrical solder at your favorite auto parts store or Walmart or wherever. Make sure you get a fuse holder rated for at least the LRA amps. If you don't have any, grab a cheap toothbrush, some 90% alcohol, qtips, and an exacto knife. Solder flux is helpful but optional. If you buy some, get water soluble non acid flux.

Using the toothbrush, qtips, and alcohol, clean up the dirty on your circuit board. Get rid of all the black burnt bug and arc flash residue. Scrape off the burnt circuit trace with the exacto knife and clean up with alcohol.

Measure the motor ohms at the connector to make sure it is solid. Disconnect the motor from the board, measure ohms, and plug back in. Measure ohms on the board to verify. If you have a burnt pin, well you have more rework to do. If your motor doesn't agree with the service manual ohms, time for a new one.

Find a good place for the fuse holder to live once the board is installed. That way if you ever have to change the fuse, it's not a big deal. Make sure the wires can't get pinched during reassembly.

Looking at the picture of the damage, you'll be attaching one wire of the fuse holder to the left hand trace marked +310v. Scrape away a little green near the connector and solder a good blob onto the terminal and trace you just exposed. While you're there, rework the next terminal over that arced also. It's marked GND.

Once the connector terminals look good, solder one wire of the fuse holder to the left hand blob over the trace. This connection will carry 310 volts, so make sure it isn't super close to any other conductive things that can help it arc out.

The other wire of the fuse holder will attach to the board above the triangle with the exclamation point. I would attach it to the siver terminal above where the burnt trace is. Again, make a solder blob, then attach the wire to the blob.

The next step is up to you. If you feel confident in your repair, paint the bottom of the board to insulate it. If not, loosely assemble the unit and test operation.

Use a fuse rated close to the locked rotor amps in the fuse holder. The motor will draw locked rotor amps for a few milliseconds every time it starts, then quickly drop off to running amps. If it runs for two minutes and nothing bad happened, you're probably good to go.

If you weren't confident, disassemble the board from the unit and paint it. I use gloss enamel. Don't use stop rust paint, it has zinc in it, which can conduct electricity on a bad day. 3 light coats about 10 minutes apart. Let it sit and dry for a couple hours and reassemble.

Last edited by jeff5may; 06-24-20 at 11:57 AM.. Reason: Information
jeff5may is offline   Reply With Quote
The Following User Says Thank You to jeff5may For This Useful Post:
nokiasixteth (07-02-20)