View Single Post
Old 06-08-14, 06:57 PM   #31
NeilBlanchard
Journeyman EcoRenovator
 
NeilBlanchard's Avatar
 
Join Date: Dec 2009
Location: Maynard, MA Eaarth
Posts: 383
Thanks: 78
Thanked 39 Times in 32 Posts
Default

Quote:
Originally Posted by NeilBlanchard View Post
So, I bought an electric branch chipper:


(click on image for link)

It works quite well. I have misplaced my Kill-A-Watt so I don't know what it consumes, yet. I have chipped about 3/4 of the new storm-downed branches, and then I have to work my way through the older branches. About four of my neighbors want to buy into it, and I'm happy about that. It fits up to 2 1/2" diameter branches, but in the real world it is the bends and curves of the branch that limits what you can chip.

Also, I want to save the larger sections for use in a wood stove or fireplace. The blades are not as sharp as when it was new, so anything above 1" or so takes careful feeding to not bog down the motor -- I have not blown the breaker yet. You have to hold *back* on the larger pieces to keep them from getting pulled in too fast. It is the smaller boughs that are so bulky and not worth burning, and these are a piece of cake for this chipper, even with about 7 or 8 hours of use on the blades.

The pile of chips is fairly impressive -- it's about 14' x 10' oval and over a foot deep in the middle. :-) I'll post a picture when I can.

By the way, it also shreds leaves and small twigs up to 1/2" diameter using the hopper, and it has a large (about 6' long x 2' dia) heavy duty filter bag, if you want to control where the chips go more precisely than just pointing the outlet.
Okay, I have a troubleshooting question: the 1.5HP 14A electric motor has a circuit breaker on the side of the motor housing that is shutting off prematurely. It is getting warm to the touch. Is this something I can fix, do you think? It never did this before.

NeilBlanchard is offline   Reply With Quote