EcoRenovator

EcoRenovator (https://ecorenovator.org/forum/index.php)
-   Geothermal & Heat Pumps (https://ecorenovator.org/forum/forumdisplay.php?f=10)
-   -   Circuit board replacement parts (from mini-split) (https://ecorenovator.org/forum/showthread.php?t=7267)

nokiasixteth 05-17-20 10:37 PM

Circuit board replacement parts (from mini-split)
 
2 Attachment(s)
Does any one know where to order replacement parts for these things . I had a grasshopper get on my outdoor circuit board some howand fry itself . Now it feels like i am going to fry as summer keeps coming down in the south :D . Any one that knows where to find replacement parts this would be awesome . I have the air con blue wave series 2 ton mini split . The first 1 ton i bought years ago is still chugging along

https://ecorenovator.org/forum/attac...1&d=1589769736

https://ecorenovator.org/forum/attac...2&d=1589769736

NiHaoMike 05-19-20 11:56 PM

Try cleaning up the burned spot and bridging the burned track. If it then works, conformal coat it to guard against further arc flash events.

jeff5may 05-20-20 08:18 PM

Here's the web page for your unit:

http://airconint.com/wiki/index.php?title=Blue_Series_3

It looks like the power feed for the outdoor fan motor got burnt. I would definitely check the resistance between the two terminals on the motor connector before I did a board repair. The service manual for your model should have some typical values for reference.

Also, how old is the unit? It may still have warranty coverage. If so, you should be able to send the pics to the manufacturer and get a new circuit board. I'd definitely verify that it's out of warranty before attempting a board level repair.

nokiasixteth 05-23-20 12:59 PM

It is about 1 yr or so old . It is possible . I havent even thought about it still being under warranty. That may be a possibility.

WyrTwister 06-11-20 10:42 PM

We had a brown out during a snow storm , several years ago . Damaged the PC board on our 12,000 BTU Fredrich mini split .

I purchased it locally at a HVAC supply house . They warrantied it for me . :-)

Seems like the board would have cost around $ 350 , if it had not of been under warranty ?

Wyr
God bless

nokiasixteth 06-23-20 08:50 PM

Its like a year old . But i installed my self. The guys who are on the page are absolutely not a lick of help . Only pc board i have found was around 350. THinking its time to youtube and figure out how to replace parts on that board . Thats lot higher than i want to spend.

Quote:

Originally Posted by jeff5may (Post 62612)
Here's the web page for your unit:

http://airconint.com/wiki/index.php?title=Blue_Series_3

It looks like the power feed for the outdoor fan motor got burnt. I would definitely check the resistance between the two terminals on the motor connector before I did a board repair. The service manual for your model should have some typical values for reference.

Also, how old is the unit? It may still have warranty coverage. If so, you should be able to send the pics to the manufacturer and get a new circuit board. I'd definitely verify that it's out of warranty before attempting a board level repair.


nokiasixteth 06-23-20 08:52 PM

You happen to have any recomendations on what type solder to use. I have not got the faintest clue where to start

Quote:

Originally Posted by NiHaoMike (Post 62590)
Try cleaning up the burned spot and bridging the burned track. If it then works, conformal coat it to guard against further arc flash events.


jeff5may 06-24-20 09:30 AM

If you didn't submit registration paperwork, your warranty is moot. It had to have been given a thumbs up by a licensed HVAC tech and submitted within 90 days. The approving tech is supposed to put a valid EPA license number on the warranty registration in order for the manufacturer to honor anything. The tech support crews only want to deal with licensed techs, not end-user customers. I imagine you didn't spend 5000 dollars on the system, so even if you have to buy a new board, you'll still come out way ahead.

Ok so here's what I would do:

Check the motor out. Find the LRA (locked rotor amps) and RLA (running load amps) for the motor. LRA is usually like 10x the running amps.

Grab a blade fuse holder and electrical solder at your favorite auto parts store or Walmart or wherever. Make sure you get a fuse holder rated for at least the LRA amps. If you don't have any, grab a cheap toothbrush, some 90% alcohol, qtips, and an exacto knife. Solder flux is helpful but optional. If you buy some, get water soluble non acid flux.

Using the toothbrush, qtips, and alcohol, clean up the dirty on your circuit board. Get rid of all the black burnt bug and arc flash residue. Scrape off the burnt circuit trace with the exacto knife and clean up with alcohol.

Measure the motor ohms at the connector to make sure it is solid. Disconnect the motor from the board, measure ohms, and plug back in. Measure ohms on the board to verify. If you have a burnt pin, well you have more rework to do. If your motor doesn't agree with the service manual ohms, time for a new one.

Find a good place for the fuse holder to live once the board is installed. That way if you ever have to change the fuse, it's not a big deal. Make sure the wires can't get pinched during reassembly.

Looking at the picture of the damage, you'll be attaching one wire of the fuse holder to the left hand trace marked +310v. Scrape away a little green near the connector and solder a good blob onto the terminal and trace you just exposed. While you're there, rework the next terminal over that arced also. It's marked GND.

Once the connector terminals look good, solder one wire of the fuse holder to the left hand blob over the trace. This connection will carry 310 volts, so make sure it isn't super close to any other conductive things that can help it arc out.

The other wire of the fuse holder will attach to the board above the triangle with the exclamation point. I would attach it to the siver terminal above where the burnt trace is. Again, make a solder blob, then attach the wire to the blob.

The next step is up to you. If you feel confident in your repair, paint the bottom of the board to insulate it. If not, loosely assemble the unit and test operation.

Use a fuse rated close to the locked rotor amps in the fuse holder. The motor will draw locked rotor amps for a few milliseconds every time it starts, then quickly drop off to running amps. If it runs for two minutes and nothing bad happened, you're probably good to go.

If you weren't confident, disassemble the board from the unit and paint it. I use gloss enamel. Don't use stop rust paint, it has zinc in it, which can conduct electricity on a bad day. 3 light coats about 10 minutes apart. Let it sit and dry for a couple hours and reassemble.

NiHaoMike 06-24-20 09:49 AM

Quote:

Originally Posted by nokiasixteth (Post 62750)
You happen to have any recomendations on what type solder to use. I have not got the faintest clue where to start

Go with good quality (e.g. Kester) 63/37 leaded solder. Lead free is harder to work with so I do not recommend it for a beginner. For the iron, go for the TS100 if you want one that's portable or a T12 if you want a budget option.

Practice a bit on a scrap board, but it looks like a pretty easy soldering job.
https://www.youtube.com/watch?v=ZwU9SqO0udU

nokiasixteth 07-02-20 09:47 PM

Thanks @jeff5may . Na i didnt pay 5k for it new . I paid like 1300 for the system and installed it my self . Never figured a grasshopper would do such . I am off tomar so i will attempt the repair following your instructions .


All times are GMT -5. The time now is 03:20 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Ad Management by RedTyger